読者です 読者をやめる 読者になる 読者になる
備忘録とか。

mikutter - ubuntu10.0

未だに起動出来ず。 昨日試したubuntuを起動したらキーボード操作やらディスプレイ周りのドライバが破損してたのでvbに入ってたFedora13で再チャレンジ。

・システム構成はこんな感じ

f:id:KingCrimson96:20130614003048p:plain

Ruby2.0.0使用。

で mikutter.rb実行時のエラーメッセージがこれ

[root@localhost trunk]# ruby mikutter.rb
/usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- gtk2 (LoadError)
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/mui/gtk_skin.rb:3:in `'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:97:in `miquire_original_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:94:in `file_or_directory_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:75:in `block in miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `each'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:17:in `miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/user.rb:4:in `'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:97:in `miquire_original_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:94:in `file_or_directory_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:75:in `block in miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `each'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:17:in `miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/service.rb:5:in `'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /usr/local/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:97:in `miquire_original_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:94:in `file_or_directory_require'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:75:in `block in miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `each'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:74:in `miquire'
    from /tmp/ruby-2.0.0-p195/mikutter/trunk/core/miquire.rb:17:in `miquire'
    from mikutter.rb:33:in '
'

■参考ブログ ・Fedora16上でのmikutter起動について
 http://matea2.blogspot.jp/2011_11_14_archive.html

・gtk2のインストールについての公式ドキュメント
 http://rubygems.org/gems/gtk2

・LinuxでRubyのインストール
 http://www.kkaneko.com/rinkou/ruby/rubybuildlinux.html

Fedora16, Ruby1.8.1で試してみます。

■メモ ・gtk2はGUIアプリケーションで使われるツールキット
・コンパイル、make忘れない
・定期的にスナップショット撮る
・fedoraでrootへ切り替えは su -
・ubuntuはsudo su -

スポンサードリンク