読者です 読者をやめる 読者になる 読者になる
備忘録とか。

mikutter動きました...

やっと...やっとです...

Fedora16上でmikutter起動できました...

f:id:KingCrimson96:20130615013603p:plain

コマンドのログの発掘したことがないので明日にでも追記に載せておきます。
( 再起動掛けてしまったのでhistoryからは不可 )

えーっと 昨日ubuntuが壊れて Fedora13で試してみたら「gtk2が入ってないよ!」と怒られて寝てたんだっけな

で、今日はこんな感じの環境で試しました。

f:id:KingCrimson96:20130615020835p:plain

Rubyのversionは1.9.3p429(2013-05-15 revesion 40747) [i686-linux]

前回と同様の操作を行い、いざmikutterを起動しようとしたところで またしてもgtk2が足りない云々と表示されたのでもう一度Google先生にお尋ねしたところ、 使用環境はubuntuですが良さげな記事がヒットしたのでそれを参考に。

mikutter with rbenv on Ubuntu 12.04
( ka_さんありがとうございます )

自分の場合はFedoraなので

yum install libgtk2.0

でgtk2の共通ライブラリを

gem install gtk2 -no-ri --no-rdoc

でgtk2のgemをインストール optionはドキュメントはいらないよーとかそんなんです。

あとは

cd ~/../tmp/ruby-1.9.3-p429/mikutter/trunk  
./configure
make    
ruby mikutter.rb

こんな感じでコンパイル&起動。
いちいちtmpの中潜るのもどうかと思いますので, ランチャに登録するなりhome直下に置いてやるなりしてあげてください。

スポンサードリンク